Obtenir Subclipse en Aptana pour travailler avec la nouvelle version de Subversion

voix
34

La version de Subclipse (1.2.4) actuellement disponible via automatique de Aptana Plugins Manager ne fonctionne pas avec la dernière version de Subversion.

Je vois sur le site Web de Subclipse mais qu'ils ont pour Eclipse 1.4.2. Donc , j'ai ajouté un nouveau site de mise à jour à distance à mon gestionnaire de mise à jour. Quand j'ai essayé de l' installer, il m'a dit que je devais Mylyn 3.0.0 . Je suis donc après beaucoup de recherches et trouvé 3.0.0 Mylyn ajouté un nouveau site de mise à jour à distance à mon gestionnaire de mise à jour. Puis , quand j'ai essayé d'installer, il me dit que je devais org.eclipse.ui 3.3.0 ou équivalent.

En regardant les détails de configuration pour Aptana, on dirait qu'il est construit contre Eclipse 3.2.2.

Est-ce que quelqu'un sait s'il y a un moyen de mettre à jour la version d'Eclipse Aptana qui est construit contre à 3.3.0? Ou s'il y a une autre façon d'obtenir Subclipse de travailler avec la nouvelle version même de Subversion?

Je sais que ce n'est pas nécessairement une « programmation » question, mais j'espère que c'est ok, car il est très pertinent à l'expérience de la programmation.

Créé 01/08/2008 à 14:56
source utilisateur
Dans d'autres langues...                            


4 réponses

voix
16

Subclipse ne nécessite pas Mylyn, mais le site de mise à jour inclut un plug-in qui intègre Mylyn et Subclipse. Ceci est destiné aux personnes qui utilisent Mylyn. Dans votre cas, vous voulez simplement désélectionner Mylyn dans la boîte de dialogue de mise à jour.

Subclipse exige également Subversion 1.5 et la version correspondante des bibliothèques natives javahl. J'ai écrit le début d'une FAQ pour aider les gens à comprendre javahl et comment l'obtenir. Voir: http://desktop-eclipse.open.collab.net/wiki/JavaHL

Créé 15/09/2008 à 14:26
source utilisateur

voix
6

J'ai eu des problèmes avec javahl dans Eclipse Ganymede, quand il a bien fonctionné dans Eclipse Europa. Je ne sais pas comment Aptana est différent, mais vous pouvez soit essayer la mise à niveau javahl ou de passer à la mise en œuvre SVNKit pure java au sein de la configuration Subclipse.

Créé 01/08/2008 à 15:41
source utilisateur

voix
4

si vous n'êtes pas allez utiliser mylyn il suffit de décocher cette dépendance. Je ne suis pas vraiment familier avec Aptana, mais éclipse vous pouvez développer ce qui est en cours d'installation et décochez tout ce que vous n'avez pas besoin.

Créé 29/08/2008 à 00:47
source utilisateur

voix
3

J'ai utilisé l'URL de mise à jour et j'ai installé l'adaptateur javahl, le projet Subclipse lui - même et l'adaptateur SVNKit BETA.

Après cela, il a bien fonctionné pour moi, ceci est pour plate-forme Linux espère que cela fonctionne pour vous.

Créé 26/08/2008 à 14:41
source utilisateur

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more