PowerBI AADSTS90002: locataire permet pas trouvé

voix
6

Référence: Alimentation BI Solution échantillon

J'ai déplacé le code nécessaire de la solution d'échantillon à ma solution et son me donner l'erreur suivante lors de l'authentification:

AADSTS90002: locataire permet pas trouvé. Cela peut se produire s'il n'y a pas d'abonnements actifs pour le locataire. Vérifiez auprès de votre administrateur d'abonnement.

J'authentifiez avec ces 2 lignes:

 var authenticationContext = new AuthenticationContext(AuthorityUrl);
 var authenticationResult = await authenticationContext.AcquireTokenAsync(ResourceUrl, ApplicationId, credential);

L'erreur se produit sur la dernière ligne. Ci-dessous sont des valeurs dans mon web.config:

<add key=authorityUrl value=https://login.windows.net/common/oauth2/authorize/ />
<add key=resourceUrl value=https://analysis.windows.net/powerbi/api />

Encore une fois, cela fonctionne à 100% dans l'application de l'échantillon, mais pas quand je propose à mon application. Toutes les idées pourquoi?

Merci d'avance pour votre aide.

Créé 27/11/2018 à 15:17
source utilisateur
Dans d'autres langues...                            


2 réponses

voix
10

Ainsi, après quelques recherches, je trouve qu'il était à voir avec la version des packages NuGet suivants:

Microsoft.IdentityModel.Clients.ActiveDirectory
Microsoft.PowerBI.Api

Les versions suivantes nécessaires à utiliser:

Microsoft.IdentityModel.Clients.ActiveDirectory v3.13.9
Microsoft.PowerBI.Api V2.0.12

Il semble qu'il a quelque chose à voir avec les points d'extrémité qui sont utilisés. Si vous passez aux versions ci-dessus (qui sont les mêmes versions utilisées dans l'outil d'échantillon fourni), il fonctionne.

Les dernières versions utilisent quelque chose comme ceci: https://login.microsoftonline.com/common/où les versions fournies dans les mêmes usages:https://login.windows.net/common/oauth2/authorize/

Une fois que je « déclassé » mes versions, il authentifiées!

J'espère que ceci aide quelqu'un d'autre.

Créé 28/11/2018 à 10:36
source utilisateur

voix
2

Résolu en retournant l'assemblée « Microsoft.IdentityModel.Clients.ActiveDirectory » à la version = 3.13.9.1126.

L'utilisation dernière version de cette assemblée a soulevé cette question. Version = 4.4.0.0

Créé 05/12/2018 à 05:59
source utilisateur

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more