Pourquoi SQL Expect paramètre à entier et mysqli?

voix
0

Je suis arrivé 2 avertissements.

Premier :

mysqli_connect () attend paramètre 5 soit entier, chaîne donnée dans C: \ xampp \ htdocs \ admin \ config \ koneksi.php sur la ligne 11

Ma ligne 11 est

$koneksi    = mysqli_connect($server,$id_user,$nama,$username,$password,$level);    

Seconde :

mysqli_select_db () attend le paramètre 1 pour être mysqli, null donnée dans C: \ xampp \ htdocs \ admin \ config \ koneksi.php sur la ligne 12

Ma ligne 12 est

$selected   = mysqli_select_db($koneksi, $database)or die(Couldn't open database $database);

complet code

<?php
$server = localhost;
$id_user = ;
$nama   = ;
$username = root;
$password = ;
$level  = ;
$database = penjualan;

$koneksi    = mysqli_connect($server,$id_user,$nama,$username,$password,$level);
$selected   = mysqli_select_db($koneksi, $database)or die(Couldn't open database $database); 
?>

Im en utilisant PHP 7. Merci pour toute aide.

Créé 02/09/2018 à 05:06
source utilisateur
Dans d'autres langues...                            


1 réponses

voix
0

Je pense que vous passez des paramètres erronés.

c'est correctement comment doivent être transmis les paramètres.

mysqli_connect(host,username,password,dbname,port,socket);
  • hôte en option. Indique un nom d'hôte ou une adresse IP
  • nom d'utilisateur en option. Indique le nom d'utilisateur MySQL
  • mot de passe en option. Indique le mot de passe MySQL
  • dbname en option. Indique la base de données par défaut à utiliser
  • Port en option. Indique le numéro de port pour tenter de se connecter au MYSQLServer
  • Prise en option. Spécifie la douille ou canal nommé à utiliser

Donc, dans votre cas, je pense qu'il devrait être

mysqli_connect($server,$username,$password,$database); 
Créé 02/09/2018 à 05:15
source utilisateur

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more