indentation correcte dans l'initialisation du tableau, PDT / Zend Studio

voix
7

J'utilise le style suivant de l'initialisation du tableau dans le code:

$a = array(
    'one' => 123,
    'two' => 456
);

Mais PDT / Zend Studio ne fonctionne pas correctement dans ce cas; après avoir appuyé sur [Retour] touche, il place le curseur sous l'un $ (dans mon exemple) et ne tient pas compte indentation. Si les clés du tableau sont des nombres (au moins pas commencer par des guillemets) tout fonctionne bien.

Voici comment cela fonctionne actuellement (| - est une position où edtitor place caret après avoir appuyé sur [Retour])

$a = array(
    'one' => 123,[RETURN]
|
);

Cela devrait résultat:

$a = array(
    'one' => 123,[RETURN]
    |
);

Ainsi est-il possible de forcer éditeur suivre mes règles d'indentation?

Créé 27/08/2009 à 06:07
source utilisateur
Dans d'autres langues...                            


7 réponses

voix
3

J'ai eu récemment exactement la même question. Je l'ai résolu dans le Zend Studio (Eclipse IDE basé) en allant

Preferences -> PHP -> Code Style -> Formatter

puis choisissez l'option Modifier à l'écran à côté du nom de la présélection de fortmatter. Dans la fenêtre ouverte allez dans l'onglet Habillage de ligne et dans la liste choose

Expressions -> Array Initializers.

Jouez avec les paramètres à votre grés.

Cordialement

Lukas

Créé 14/12/2010 à 14:20
source utilisateur

voix
1

Je vous suggère de créer un compte dans la liste des pistes bugzilla, et le vote pour la fonction suivante:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=320130

S'il y a assez de gens, ils intègrent probablement ces fonctionnalités dans la version supplémentaire de PDT.

Créé 12/10/2010 à 00:10
source utilisateur

voix
1

En ZendStudio vous pouvez appliquer le PhpCodeFormatter en utilisant Ctrl+ Shift+ F.

Le formateur peut être configuré dans Fenêtre-> Préférences-> PHP-> reformater tableaux code Style-> Formatter (Zend Studio 7.0) comme décrit ci-dessus.

PDT, (pour autant que je sache) ne possède pas cette fonction.

Créé 27/08/2009 à 10:27
source utilisateur

voix
0

Essayer

Fenêtre-> Préférences
PHP-> Code de Style-> Formatter
Indentation-> dafault pour Indentation initialiseurs tableau = 1

Créé 21/04/2014 à 14:46
source utilisateur

voix
0

Non, c'est bug Eclipse.

Je l'ai fait face à l'aide de tous les éditeurs de texte Eclipse (SQL, XML, YML, écossés, et o) sur.

Cependant, il arrive que mon installation Eclipse pour Linux (Kubuntu karmique) sur x86_64. Je l'ai testé sur i386 karmique à mon travail et il fonctionne très bien.

Créé 26/04/2010 à 01:43
source utilisateur

voix
0

@MGriesbach: En fait PDT (Eclipse) ne possède cette fonction (sous Source-> Format)

@Sergei: Eclipse n'a pas ce problème, mais cela ressemble à quelque chose ne va pas avec votre config. Êtes-vous sûr regardé toutes les options? Vous pouvez également envoyer un e-mail à l'équipe Zend, cela ressemble à un bug assez trivial sur le côté héritier, car il encourage les développeurs à écrire du code non dentelée correctement.

-- modifier--

Mon mauvais, Eclipse PDT n'ont ce problème mais je m'y suis habitué :) Le problème disparaît si je presse onglet, il indentera la première ligne. Les autres lignes suivront correctement.

Créé 02/09/2009 à 13:25
source utilisateur

voix
0

Je ne suis pas sûr Eclipse, mais j'ai eu le même problème dans TextMate. Je suis passé à onglets doux (aka 4 places) au lieu des onglets et il agit maintenant comme « prévu ». ZendStudio Est-ce que cette option existe?

Créé 27/08/2009 à 22:18
source utilisateur

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more